Vuex state property name - convention or requirement?












0















From all tutorials on Vuex that I've read, the state is always maintained in a property named state in the Vuex.Store object.



My question is whether this property has to be named state or can it be named something else? From my experiments, it seems that it has to be called state, but I would like to have confirmation from people who are more experienced in Vue.



Related, does the Vuex store have to be named as store in Vue as a requirement or convention?



new Vue({
...
store,
...
});



My hunch is that store is a strong convention - breaking it would break interoperability with plugins, and that state seems to be a requirement in Vuex.Store.










share|improve this question



























    0















    From all tutorials on Vuex that I've read, the state is always maintained in a property named state in the Vuex.Store object.



    My question is whether this property has to be named state or can it be named something else? From my experiments, it seems that it has to be called state, but I would like to have confirmation from people who are more experienced in Vue.



    Related, does the Vuex store have to be named as store in Vue as a requirement or convention?



    new Vue({
    ...
    store,
    ...
    });



    My hunch is that store is a strong convention - breaking it would break interoperability with plugins, and that state seems to be a requirement in Vuex.Store.










    share|improve this question

























      0












      0








      0








      From all tutorials on Vuex that I've read, the state is always maintained in a property named state in the Vuex.Store object.



      My question is whether this property has to be named state or can it be named something else? From my experiments, it seems that it has to be called state, but I would like to have confirmation from people who are more experienced in Vue.



      Related, does the Vuex store have to be named as store in Vue as a requirement or convention?



      new Vue({
      ...
      store,
      ...
      });



      My hunch is that store is a strong convention - breaking it would break interoperability with plugins, and that state seems to be a requirement in Vuex.Store.










      share|improve this question














      From all tutorials on Vuex that I've read, the state is always maintained in a property named state in the Vuex.Store object.



      My question is whether this property has to be named state or can it be named something else? From my experiments, it seems that it has to be called state, but I would like to have confirmation from people who are more experienced in Vue.



      Related, does the Vuex store have to be named as store in Vue as a requirement or convention?



      new Vue({
      ...
      store,
      ...
      });



      My hunch is that store is a strong convention - breaking it would break interoperability with plugins, and that state seems to be a requirement in Vuex.Store.







      vue.js vuex






      share|improve this question













      share|improve this question











      share|improve this question




      share|improve this question










      asked Jan 2 at 8:09









      cheezecheeze

      237210




      237210
























          1 Answer
          1






          active

          oldest

          votes


















          1














          It has to be called state.



          If you named it something else, how should Vuex know that you intend for that other property to represent the state?



          However the store instance can be named anything you want - but the property hat you add to the new Vue has to be called store:



          const myStore = new Vuex.Store(...) // name this variable as you want

          new Vue({
          ...
          store: myStore, // but the property has to be called `store`
          ...
          });





          share|improve this answer

























            Your Answer






            StackExchange.ifUsing("editor", function () {
            StackExchange.using("externalEditor", function () {
            StackExchange.using("snippets", function () {
            StackExchange.snippets.init();
            });
            });
            }, "code-snippets");

            StackExchange.ready(function() {
            var channelOptions = {
            tags: "".split(" "),
            id: "1"
            };
            initTagRenderer("".split(" "), "".split(" "), channelOptions);

            StackExchange.using("externalEditor", function() {
            // Have to fire editor after snippets, if snippets enabled
            if (StackExchange.settings.snippets.snippetsEnabled) {
            StackExchange.using("snippets", function() {
            createEditor();
            });
            }
            else {
            createEditor();
            }
            });

            function createEditor() {
            StackExchange.prepareEditor({
            heartbeatType: 'answer',
            autoActivateHeartbeat: false,
            convertImagesToLinks: true,
            noModals: true,
            showLowRepImageUploadWarning: true,
            reputationToPostImages: 10,
            bindNavPrevention: true,
            postfix: "",
            imageUploader: {
            brandingHtml: "Powered by u003ca class="icon-imgur-white" href="https://imgur.com/"u003eu003c/au003e",
            contentPolicyHtml: "User contributions licensed under u003ca href="https://creativecommons.org/licenses/by-sa/3.0/"u003ecc by-sa 3.0 with attribution requiredu003c/au003e u003ca href="https://stackoverflow.com/legal/content-policy"u003e(content policy)u003c/au003e",
            allowUrls: true
            },
            onDemand: true,
            discardSelector: ".discard-answer"
            ,immediatelyShowMarkdownHelp:true
            });


            }
            });














            draft saved

            draft discarded


















            StackExchange.ready(
            function () {
            StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fstackoverflow.com%2fquestions%2f54003098%2fvuex-state-property-name-convention-or-requirement%23new-answer', 'question_page');
            }
            );

            Post as a guest















            Required, but never shown

























            1 Answer
            1






            active

            oldest

            votes








            1 Answer
            1






            active

            oldest

            votes









            active

            oldest

            votes






            active

            oldest

            votes









            1














            It has to be called state.



            If you named it something else, how should Vuex know that you intend for that other property to represent the state?



            However the store instance can be named anything you want - but the property hat you add to the new Vue has to be called store:



            const myStore = new Vuex.Store(...) // name this variable as you want

            new Vue({
            ...
            store: myStore, // but the property has to be called `store`
            ...
            });





            share|improve this answer






























              1














              It has to be called state.



              If you named it something else, how should Vuex know that you intend for that other property to represent the state?



              However the store instance can be named anything you want - but the property hat you add to the new Vue has to be called store:



              const myStore = new Vuex.Store(...) // name this variable as you want

              new Vue({
              ...
              store: myStore, // but the property has to be called `store`
              ...
              });





              share|improve this answer




























                1












                1








                1







                It has to be called state.



                If you named it something else, how should Vuex know that you intend for that other property to represent the state?



                However the store instance can be named anything you want - but the property hat you add to the new Vue has to be called store:



                const myStore = new Vuex.Store(...) // name this variable as you want

                new Vue({
                ...
                store: myStore, // but the property has to be called `store`
                ...
                });





                share|improve this answer















                It has to be called state.



                If you named it something else, how should Vuex know that you intend for that other property to represent the state?



                However the store instance can be named anything you want - but the property hat you add to the new Vue has to be called store:



                const myStore = new Vuex.Store(...) // name this variable as you want

                new Vue({
                ...
                store: myStore, // but the property has to be called `store`
                ...
                });






                share|improve this answer














                share|improve this answer



                share|improve this answer








                edited Jan 2 at 15:07

























                answered Jan 2 at 8:56









                Linus BorgLinus Borg

                11.7k13839




                11.7k13839
































                    draft saved

                    draft discarded




















































                    Thanks for contributing an answer to Stack Overflow!


                    • Please be sure to answer the question. Provide details and share your research!

                    But avoid



                    • Asking for help, clarification, or responding to other answers.

                    • Making statements based on opinion; back them up with references or personal experience.


                    To learn more, see our tips on writing great answers.




                    draft saved


                    draft discarded














                    StackExchange.ready(
                    function () {
                    StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fstackoverflow.com%2fquestions%2f54003098%2fvuex-state-property-name-convention-or-requirement%23new-answer', 'question_page');
                    }
                    );

                    Post as a guest















                    Required, but never shown





















































                    Required, but never shown














                    Required, but never shown












                    Required, but never shown







                    Required, but never shown

































                    Required, but never shown














                    Required, but never shown












                    Required, but never shown







                    Required, but never shown







                    Popular posts from this blog

                    Monofisismo

                    Angular Downloading a file using contenturl with Basic Authentication

                    Olmecas